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About This Manual
 
This documentation provides you with useful information and tips on how to use the Carl Valentin GmbH.
 
Who Should Read This Manual
 
This manual is intended for end users of Labelstar Office Lite and provides a general description of the application.
 
How This Manual Is Organized
 

Installation - This section identifies the system requirements and walks you through the program installation.
Getting Started - This section provides information about the user interface and instructions on working with
the basic functions of the Labelstar Office Lite.
Create Your First Label - Here you will find a step-by-step guide explaining how to create a simple label with
Labelstar Office Lite.
Barcodes - This section gives you an overview of the supported barcode types.
Variables - This section gives you an overview of the supported variable types.
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Document Conventions
 
The following symbols and text conventions are used in this documentation:
 
Symbol/Convention Description

  WARNING - Provides a critical warning. You should always read warnings, like this one. They
will help you avoid making serious mistakes, or wasting your time.

  IMPORTANT - Provides clarifying information or specific instructions. It is recommended
that you read the text or follow the link.

  NOTE - Provides a tip, guidance, or advice, emphasizes important information, or provides a
reference to related information.

  EXAMPLE - Provides references to sample files.

Save Name of buttons, windows, menu items and other program interface elements.
[CTRL] Keyboard keys.
C:\Windows\ Name of files and folders, code examples.
<UserName> Placeholders.
Appendix A Cross-references to other locations in the document or internal hyperlinks to web pages.
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Installation
 
This section identifies the system requirements and walks you through the program installation.
 

Before installing Labelstar Office Lite - Please check if your computer fulfills the system requirements.
This ensures that the installation can be completed correctly.

 
System Requirements
 
Operating System
 

Windows 10/11
Windows Server 2016/2019/2022

 
.NET Framework
 

.NET Framework 4.7.2 or later
The installer will automatically install all required .NET Framework components
Active internet connection to update .NET Framework

 
Click the link below for instructions on installing the latest version of the .NET Framework on your computer:
 

Install the .NET Framework on Windows 10 and Windows Server 2016 and later
 
First-Time Installation
 

Administration rights are required for the installation.

 
1. Download the current program version from www.labelstar-lite.carl-valentin.de.
2. Run the downloaded file as administrator and follow the instructions on the screen.

The program is now installed on your computer and can be used.
 

If an older version of Labelstar Office Lite is already installed, you can just install the new version over it.
There is no need to uninstall the old version first. Your existing settings will be retained.

 

https://docs.microsoft.com/en-us/dotnet/framework/install/on-windows-10
https://www.carl-valentin.de/en/downloads/software/labelstar-office-lite/
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Program Variants
 
Labelstar Office comes in two variants - the Lite and the Standard version.
 
The free Lite version, which lacks many features compared to the Standard version, is intended to design simple
labels. For professional requirements, use the Standard version.
 
If you’d like to try it out, you can download a free trial of the Standard version from here: www.labelstar.carl-
valentin.de
 
  STANDARD LITE
Text Objects    
  TrueType fonts

  Printer fonts  

  Text formatting (markup tags)  

  Curved text  

Barcode Objects    
  1D Barcodes

  2D Barcodes  

  GS1 Barcodes  

  Post Barcodes  

  HIBC Barcodes  

Images More than 90 graphic and vector
formats (e. g. TIFF, GIF, JPEG, PNG,
WMF, BMP, ICO, and many more)

Limited (BMP only)

  PFD import  

Variables    
  System variables More than 30 variables (e. g.

counter, date, time, user input,
field link, check digit calculation,

if...else statement, and many more)

Limited (date, time, counter,
and user input only)

  Printer variables  

Databases  
Logging  
Memory Card Support  
Symbols  
Label Export    
  SAPscript ITF print template  

  PDF files  

  Image files  

Printing    
  Internal printer protocoll (CVPL)

(Valentin printer driver
Version 2.4.1 or later)

(Data is transfered graphically.)

  Print preview  

http:\www.labelstar.carl-valentin.de
http:\www.labelstar.carl-valentin.de
https://www.carl-valentin.de/en/downloads/printer-drivers/
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  Column printing  

  Two-color printing  

API LSOffice.dll  
Import Labelstar Plus/Lite Labels  

  Label Converter  

Program Modules    
  Label Designer

  Print Manager (batch processing)  

  Quick Print  

  Print Form  

  Folder Monitor  
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Getting Started
 
This section describes the main window and the basic functions of Labelstar Office Lite.
 
User Interface
 

 

Title Bar
The title bar displays the program name and the label name that is currently being edited.
 
On the left side of the title bar, the Quick Access Toolbar lets you perform common tasks with just one
click:
 

 - Open label

 - Save label

 - Undo last command

 - Redo last command

 - Print label
 
The Minimize, Maximize/Restore and Close window control buttons are grouped on the right side of the
title bar.

Ribbon
The ribbon gives you access to all functions of Labelstar Office Lite. For a better overview, the ribbon is
divided into tabs. In each tab, you can find groups that are related to each other. Each group consists of
features and buttons, which are designed for similar tasks.
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Barcodes
Shows a list of the available barcode types. To add a barcode to the label, select an entry and drag it onto
the label.

Work Area
This area shows the label that you are currently editing.

Properties
Displays the properties of the object that is currently being selected.

Status Bar
In this area you will find information about:
 

 - Label size

 - Location of the selected object.
 

On the right side of the status bar are the zoom buttons and slider:
 

 - Zoom 100%

 - Zoom label width

 - Zoom whole label

 - Zoom in and out
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Program Options
 
The Labelstar Office Lite has a large number of setting options with which you can customize the program to your
personal requirements.
 
It is a good idea to check through these settings before you start working with the Labelstar Office Lite. You may be
surprised at all the things you can adjust and configure!
 
To Change the Program Options
 
1. Select the File tab, and then click Options.
  The Options dialog opens.
2. Select a tab and change the desired settings.
3. Click OK, to close the dialog.

Settings are saved.
 

All settings marked with an asterisk (*) take effect at the next application startup.

 
Program Options - General
 
Settings
 
Save label without prompt. Select this check box if the label should be saved without confirmation prompt.
 
At program startup
 
Select how Labelstar Office Lite should behave at program startup:
 

Blank label. Opens a blank label.
Open recent label. Shows the recently opened label.
Open label. Opens a particular label. Click [...] to choose a label file.
Show File Open dialog. Displays the Open File dialog box to choose a label.

 
Program Options - Printing
 
Settings
 
Default printer. You can select the default printer for Labelstar Office Lite here. Labelstar Office Lite initially uses
the Windows default printer, but you can select a different default printer for the print output. The Windows default
printer and the Labelstar Office Lite default printer are independent of one another. If you change one of the
defaults, this does not affect the other one.
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Program Options - File Locations
 
Folder Settings
 
Default labels location. Specifies the folder used by default to open or save a label. Leave this field blank to use
the default directory %UserProfile%\Documents\Labelstar Office Lite\Labels.
 
Default image location. Specifies the image folder. Leave this field blank to use the default directory
%UserProfile%\Documents\Labelstar Office Lite\Images.
 
Program Options - Language
 
You can change the language of the menus and dialog boxes used in Labelstar Office Lite.
 
Settings
 
Select an entry from the list of available languages. If the entry (Same as the system) is selected, the system
language (if language available, otherwise English) is used as program language.
 

If you have changed the language, you must quit and restart Labelstar Office Lite.
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Create Your First Label
 
The best way to learn how to design a label is to actually create one. In this section, we explain (step by step) how
to design a simple label using Labelstar Office Lite.
 
When you finish, your label will look like this:
 

 

The corresponding label file can be found at the following location: %Public%\Documents\Labelstar
Office Lite\Samples\Sample.lblx
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Step 1: Create Label
 
1. Open Labelstar Office Lite.
2. Click File > New.

A new blank label is created with the standard dimensions 100 mm x 60 mm.
 
Change Label Width to 60 mm
 
Grab the slider on the horizontal ruler with the mouse and move it to 60 mm.

 
or
 
Go to Properties > Layout, and change Label width to 60 mm.
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Step 2: Create Objects
 
In this step you will learn how to add fixed objects on the label.
 
Insert Text
 

1. On the Home tab, in the Tools group, click the  Text button.

2. Move the cursor  to the location where the text object will be inserted and click the mouse button.
  The Text Editor dialog opens.
3. Enter Hello World!, then click OK.

The text is placed on the label.
 
Use the mouse to position the text object at the top of the label.
 
Change Font
 
Go to Properties > Appearance > Font, and choose Arial font, 16 point size, and bold style.

 
The screen should show the following:
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Insert Horizontal Line
 

1. On the Home tab, in the Tools group, click the  Line button.

2. Move the cursor  to the starting point of the line.
3. Press [SHIFT] key, hold down the mouse button and move the cursor to the end position of the line, then

release the mouse button.
The line is placed on the label.

 
Use the mouse to position the line object below the text object.
 

You can draw a straight or 45° tilted line by line tool with pressing [SHIFT] key.

 
Change Line Weight
 
Go to Properties > Appearance, and change Line weight to 1 mm.

 
Change Line Size
 
Go to Properties > Layout, and change X1 to 0 mm and X2 to 60 mm.

 
The screen should show the following:
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Insert Barcode
 
Now you will add a Code 128 barcode on the label.
 
1. On the Barcodes tab, select Code 128.

2. Hold down the mouse button and move the cursor  to the desired location, then release the mouse button.
The barcode is placed on the label.

 
Use the mouse to position the barcode below the horizontal line.
 
Change Module Width
 
Go to Properties > Appearance, and change Module width to 5 pt.

 
Change Barcode Height
 
Go to Poperties > Layout, and change Height to 15 mm.

 

You can change the barcode size by dragging the object handles. The handles are small circles
surrounding the object when it is selected.

 
The screen should show the following:
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Insert Image
 

1. On the Home tab, in the Tools group, click the  Image button.

2. Move the cursor  to the location where the image object will be inserted and click the mouse button.
  The Open File dialog box opens.
3. Go to %Public%c\Documents\Labelstar Office Lite\Samples and open Globe.bmp.

The image is placed on the label.
 
Use the mouse to position the image below the barcode.
 
The screen should show the following:
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Step 3: Align Objects
 
You have placed the objects on the label. Now you want to make sure they are aligned horizontally centered of the
label.
 
1. Select all objects
  To select all objects on the label, perform one of the following actions:
  On the Home tab, in the Tools group, click the  Select button and draw a frame arround all objects on

the label.
Select an object on the label. Hold down [SHIFT] key and click another object. Repeat for all objects on the
label.
Press [CTRL] + [A].

2. On the Home tab, in the Arrange group, click Align > Align Center.
The selected objects will be rearranged and positioned on the horizontal center of the label.

 
The screen should show the following:
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Step 4: Use Variable Data
 
So far, only fixed objects have been inserted on the label. If you want to define a label which data changes during
printing, Labelstar Office Lite offers different variable fields (Counter, Date/Time, and User Input) that you can use
with text or barcode objects.
 
In this step, you change the fixed content of the barcode object to a counter that is incremented by two for each
label.
 
Insert Counter
 
1. Double-click the barcode object on the label.
  The Data Editor dialog box opens.
2. Click Insert Variable > Counter.
  The Counter dialog box opens. Change Increment to 2 and click OK.
3. Click OK to close dialog.
 
The screen should show the following:
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Step 5: Print Label
 
1. Perform one of the following actions:

 

Click File > Print.

Click  in the title bar.
Press [CTRL] + [P].

  The Print dialog box opens.
2. Choose the printer on which the labels are to be printed and enter 6 as the Number of Copies.
3. Click OK to start printing.
 
Print-Out
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Barcodes
 
This section gives you an overview of the supported barcode types.
 
Codabar
 
The Codabar is mainly used in libraries, in photo sector and in medical ranges (blood banks). The Codabar is a
universal, numeric barcode that contains 6 special characters additionally to the numbers 0 to 9. The number of
representable signs is not given of the code.
 
Additionally four different start/stop signs (A-D) are defined, i.e. each code must begin and end with A, B, C or D.
However, the start/stop signs cannot be used in the bar code itself.
 
Each sign of the code consists of elf units, four bars and three spaces. A fourth gap is always narrow.
 

 
Length Variable
Valid characters Digits 0-9

Special characters - $ : / . +
Check digit None

Modulo 16
 
Code 128
 
Code 128 is a universal, alphanumeric barcode mainly used in shipping/transport, on documents of identification
and in warehousing/distribution.
 
Code 128 can encode the complete ASCII character set. This code uses an internal check digit that won't be
displayed in the text line under the code. By the use of four different widths for bars and gaps. the information
density is very high.
 
The structure of a Code 128 consists of a start sign, data area, check digit and a stop sign. Before the start sign and
behind the stop sign a white zone (quiet zone) with a width of at least 10 modules must be defined.
 

 
Length Variable
Valid characters 128 ASCII characters

Control characters
Check digit Modulo 103
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Code 2/5 Interleaved
 
Code 2/5 Interleaved is a two-width numeric code that can encode information of any length as long as the code
contains an even number of digits.
 
Every two digits are interleaved with each other to create a single symbol. The first digit is displayed with five bars
(or black lines). The second digit is represented by the spaces (or white lines) following the bars. Five bars and
spaces encode a pair of digits.
 
If an uneven number of digits is to be displayed, a zero must be prefixed or a check digit must be added at the end.
 
The barcode is mainly used in industry, especially in logistics.
 

 
Length Variable (Even number of digits)
Valid characters Digits 0-9
Check digit None

Modulo 10
Modulo 10 (Luhn Algorithm)
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Code 39
 
Code 39 is a popular non-retail symbology mainly used in shipping/transport, electronics and chemical industries,
the health sector and in warehousing/distribution. It supports numbers, upper-case letters, and several special
characters.
 
Each character is composed of nine elements: five bars and four spaces. Three of the nine elements in each
character are wide (binary value 1), and six elements are narrow (binary value 0). The width ratio between narrow
and wide is not critical, and may be chosen between 1:2 and 1:3. The barcode itself does not contain a check digit,
but it can be considered self-checking on the grounds that a single erroneously interpreted bar cannot generate
another valid character.
 
Possibly the most serious drawback of Code 39 is its low data density: It requires more space to encode data in
Code 39 than, for example, in Code 128.
 

 
Length Variable
Valid characters Digits 0-9

Upper case letters A-Z
Special characters - . $ / + %
Space

Check digit None
Modulo 43
Modulo 11 (weighting 7)
Modulo 10 (Luhn Algorithm)

 
Code 39 Extended
 
Code 39 Extended supports all 128 ASCII characters by using double character encoding. For example, the lower-
case letter "a" is represented by "+A".
 
Because of the possibility of misrepresentation of a symbol, most barcode scanners must be switched to extended
mode in order to recognize Code 39 Extended.
 

 
Length Variable
Valid characters 128 ASCII characters
Check digit None

Modulo 43
Modulo 11 (weighting 7)
Modulo 10 (Luhn Algorithm)
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Code 93
 
Code 93 is an alphanumeric barcode similar to Code 39 and can encode 48 different characters.
 
By the use of various bar widths and gap widths it has a higher information density. Each character is nine modules
width, and always has three bars and three spaces.
 

 
Length Variable
Valid characters Digits 0-9

Upper case letters A-Z
Special characters - . $ / + %
Space

Check digit Modulo 47
 
Code 93 Extended
 
Code 93 Extended is a variant of Code 93, extending it to support all 128 ASCII characters.
 

 
Length Variable
Valid characters 128 ASCII characters
Check digit Modulo 47
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Deutsche Post Identcode
 
Identcode is a variant of Code 2/5 Interleaved, but with a different check digit. This code is used by the Deutsche
Post AG (DHL) and serves the automatic distribution of freight parcels in the post-office centres.
 
Structure of Identcode:
 

1..2: Mail center (outgoing)
3..5: Customer code
6..11: Delivery number
12: Check digit

 

 
Length 12
Valid characters Digits 0-9
Check digit Modulo 10
 
Deutsche Post Leitcode
 
Leitcode is a variant of Code 2/5 Interleaved, but with a different check digit. This code is used by the Deutsche
Post AG (DHL) and serves the automatic distribution of freight parcels in the post-office centres.
 
Structure of Leitcode:
 

1..5: ZIP code
6..8: Street's code number
9..11: House number
12..13: Product code
14: Check digit

 

 
Length 14
Valid characters Digits 0-9
Check digit Modulo 10
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EAN-13, GTIN-13
 
EAN barcodes are used world-wide for marking retail goods. Each packaging is uniquely identified by the GTIN -
Global Trade Item Number (formerly European Article Number - EAN).
 
EAN barcode sizes are standardized. The module width and height are only allowed to vary within certain limits.
The default, or 100%, size is called SC 2, resulting in a code that is roughly 26 mm high and 35 mm wide. It is
permitted to vary the width down to 81% and up to 200%. In addition it is permitted to reduce the height to some
degree, this is also known as truncation.
 
The symbol encodes 13 characters: the first two or three are a country code which identify the country in which the
manufacturer is registered (not necessarily where the product is actually made). The country code is followed by 9
or 10 data digits (depending on the length of the country code) and a single check digit.
 

EAN-13
 
EAN-13 can carry an add-on barcode. The add-on can encode another two or five digits of data. With such an add-
on EAN-13 usually encodes an ISBN or ISSN.
 

 

EAN-13 AddOn 2   EAN-13 AddOn 5
 
Length 13-18
Valid characters Digits 0-9
Check digit Modulo 10
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EAN-8, GTIN-8
 
EAN-8 is a shortened version of the EAN-13 barcode.
 
It includes a 2 or 3 digit country code, 4 or 5 data digits (depending on the length of the country code), and a check
digit.
 

A GTIN short number will only be output upon request since these numbers have limited availability.
The EAN-8 barcodes with a 2 as the starting digit can be used freely within the company, but they are
not unique in the world.

 

 
Length 8
Valid characters Digits 0-9
Check digit Modulo 10
 
ITF-14, SCC-14
 
ITF-14, which is based on Code 2/5 Interleaved, is used to create the Shipping Container Code (SSC). This code is
used to mark cartons and palettes that are including goods with an EAN-13 code.
 
A ITF-14 number contains the following information:
 

1: Package indicator
2..3: UPC numbering system/GS1 country prefix
4..8: GS1 company prefix
9..13: Item identification number
14: Check digit

 

 
Length 14
Valid characters Digits 0-9
Check digit Modulo 10
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Pharmacode
 
Pharmacode is a simple, numeric barcode placed on the marked from company Laetus. It is used in pharmaceutical
industry for the control of packaging means and/or for the control of packaging machines.
 
Pharmacode applied on the packaging and on the package insert provides that the correct package insert is sorted
into the appropriate packaging. With the Pharmacode only integers can be coded from 3 to 131070.
 

 
Length 1-6
Valid characters Digits 0-9
Check digit None
 
PZN-8
 
PZN barcodes serves for marking of drugs and other pharmacy products according to trademarks, dosage
form, intensity and package size. The PZN (Pharmazentralnummer) is assigned by the Informationsstelle für
Arzneispezialitäten (IFA).
 

 
Length 8
Valid characters Digits 0-9
Check digit Modulo 11
 

http://www.ifaffm.de
http://www.ifaffm.de
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UPC-A, GTIN-12
 
The Universal Product Code (UPC) is a barcode symbology that is widely used in the United States, Canada, the
United Kingdom, Australia, New Zealand and in other countries for tracking trade items in stores.
 
Its most common form, the UPC-A, consists of 12 numerical digits, which are uniquely assigned to each trade item.
Along with the related EAN-13 barcode, the UPC-A is the bar code mainly used for scanning of trade items at the
point of sale.
 
The symbol encodes 12 characters:
 

1: System identification
2..6: UPC ID number (manufacturer)
7..11: Individual article number (issued by the manufacturer)
12: Check digit

 

 
Length 12
Valid characters Digits 0-9
Check digit Modulo 10
 
UPC-E
 
The UPC-E is intended to be used on packaging which would be otherwise too small to use UPC-A.
 
The code is smaller because it drops out zeros which would otherwise occur in the symbol. For example, the code
59300-00066 would be encoded as 593663. The last digit (3 in the example) indicates the type of compression.
 

 
Length 8
Valid characters Digits 0-9
Check digit Modulo 10
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Variables
 
The purpose of variables is to insert certain changeable values on a label, for example the current date. This enables
flexible label design.
 

 
Variables can be used in text and barcode objects.
 
Define a Variable
 
1. Double-click the object in which you want to insert a variable.
  The Text Editor opens.
2. Position the cursor in the input field where you want to insert the variable, and click Insert Variable.
3. Choose the type of variable you want to use.
  The corresponding dialog box opens.
4. Specify the variable and click OK.
  The variable specification is displayed in the editor.
5. Click OK to close the editor.
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General Structure
 
$Variablenname (Argument1, Argument2, Argument3, ...)
 
A variable starts always with a dollar sign ($). The name of the variable follows the dollar sign, followed by the
recommended arguments in brackets. If multiple arguments are used, they are separated by commas. Texts,
numbers or other variables can be indicated as variable arguments. Some variables do not require arguments, but
the brackets are still required.
 
Reserved Characters
 
Character Definition
$ Indicates a variable.
( Indicates the beginning of the parameter list.
) Indicates the end of the parameter list.
" Delineates the beginning or ending of a string.
, Parameter separator.
= Parameter name-value separator.
 
Print Out Dollar Sign
 
Whenever a sign has a special meaning, problems will follow. In general, it is assumed that the function and not the
sign itself is meant. This means that if you enter a dollar sign, Labelstar Office Lite assumes that you want to define
a variable – the dollar sign is interpreted as the beginning of a variable.
 
What is to be done if you really want to print a dollar sign?
 
There is a very simple trick: double the dollar sign. This devalues the dollar sign and uses it as a normal sign.
 
In order to get the output "The article costs 13$" the source text must look like this: "The article costs 13$$".
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Syntax Conventions
 
The following conventions are used in the syntax statements:
 

Keywords that must be entered literally are in bold.
Parameters representing variables that must be replaced with an appropriate value or expression are in italics.
Parameters enclosed in brackets ([]) are optional.
Parameters not enclosed in brackets or parameters enclosed in braces ({}) are required.
A vertical bar (|) separates two or more parameters, of which exactly one can be selected. The default value is
underlined.

  For example, [a|b] indicates that you can choose a, b, or nothing. Similarly, {a|b} indicates that you must
choose either a or b.
Comma-Ellipsis (, ...) indicates that the parameter can optionally be repreated, separated by commas. If no
repetition is specified, the comma is omitted.
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Counter
 
Use the $Counter variable to define a simple numeric counter and display the current counter value on the label.
 
Syntax
 

$Counter ("start_value"[, UpdateInterval=update_interval][, Increment=increment])

 
 
Parameters
 
start_value (9 digits max.)

The start value to count from.
Note: The number of digits of the start value determines the output format.

 
update_interval (optional, default = 1)

Indicates how often the counter is to be incremented during a print job.
1: After each label
n: After n labels

 
increment (optional, default = 1)

A positive number to indicate the amount by which you want the counter to increase.
 
Example 1
 
Define a counter that increases by 1 on each label.
 
$Counter ("1")
 
1, 2, 3, 4, 5, 6, 7, 8, 9, 0, 1, 2, 3, 4, 5
6, 7, 8, 9, 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 0
 

The counter starts again (roll over) once it reached the maximum number, in this case 9.

 
Example 2
 
Define a counter that increases by 5 on every second label.
 
$Counter ("01", UpdateInterval=2, Increment=5)
 
01, 01, 06, 06, 11, 11, 16, 16, 21, 21
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Date/Time
 
Use the $DateTime variable to display a date and time value on the label. The value is obtained from the system
clock.
 
Syntax
 

$DateTime ("output_format"[, UpdateInterval=update_interval][, DayOffset=day_offset])

 
Parameters
 
output_format

The format in which the date and time value is displayed.
This can be either an individual format specifier (see Standard Date Formats) or a customized format
pattern (see Custom Date Formats). If output format is empty, the general format identifier "G" is used.

 
update_interval (optional, default = 1)

Indicates how often the variable is to be updated during a print job.
0: At print start
1: After each label
n: After n labels

 
day_offset (optional, default = 0)

The number of days added to the current date.
 
Examples
 
Date used in examples: 2013-09-11 13:20:35
 
$DateTime ("") -> 9/11/2013 1:20:35 PM
$DateTime ("d") -> 9/11/2013
$DateTime ("D") -> Wednesday, September 11, 2013
 
$DateTime ("MM/dd/yy", DayOffset=10) -> 09/21/13
 
$DateTime ("hh:mm") -> 01:20
$DateTime ("HH:mm") -> 13:20
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Standard Date Formats
 
Standard date and time format strings use a single format specifier to define the text representation of a date
and time value. Any date and time format string that contains more than one character, including white space, is
interpreted as a custom date format.
 
  Format specifier Output example
Date, short d 7/27/2022
  G 7/27/2022 8:57:54 AM
  g 7/27/2022 8:57 AM
Date, long D Wednesday, July 27, 2022
  F Wednesday, July 27, 2022 8:57:54 AM
  f Wednesday, July 27, 2022 8:57 AM
Time T 08:57:54 AM

  t 08:57 AM
 
Custom Date Formats
 
  Ouput example
yyyy-MM-dd HH:mm:ss 2022-07-27 14:51:18
ddd h Wed 2
yy-MM-dd (dddd) 22-07-27 (Wednesday)
 
Format Tokens
 
  Token Output
Month M 1, 2, ... 11, 12
  MM 01, 02, ... 11, 12
  MMM Jan, Feb, ... Nov, Dez
  MMMM January, February, ... November, December
Day of month d 1, 2, ... 30, 31
  dd 01, 02, ... 30, 31
Day of week ddd Sun, Mon, ... Fri, Sat
  dddd Sunday, Monday, ... Friday, Saturday
Week of year w 1, 2, ... 52, 53
  ww 01, 02, ... 52, 53
Year yy 70, 71, ... 29, 30
  yyyy 1970, 1971, ... 2029, 2030
Hour H 0, 1, ... 22, 23
  HH 00, 01, ... 22, 23
  h 1, 2, ... 11, 12
  hh 01, 02, ... 11, 12
Minute m 0, 1, ... 58, 59
  mm 00, 01, ... 58, 59
Second s 0, 1, ... 58, 59
  ss 00, 01, ... 58, 59
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User Input
 
Use the $UserInput variable to display an input control to ask the user to enter a value at print time.
 
Syntax
 

$UserInput()

 
Internal Parameters
 

 
Settings
 
Prompt text. A message to the user indicating what kind of input is expected.
 
Update interval. Here you can specify how often the user input should be displayed during a print job.
 
Start text. The text that the input control starts with. Enable the Overwrite start text after input option if you
always want to use the recently entered text.
 
Input Control Settings
 
Allowable characters. Here you can specify which characters may be entered in the input control.
 
Min length. The minimum number of characters that must be entered.
 
Max length. The maximum number of characters that may be entered.
 
To verify that the user input works like expected click Test Input.
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Example 1
 
Create a user input that accepts only numeric input.
 
Prompt text = Enter serial number:
Allowable characters = Numbers only
 

 
Example 2
 
Create a user input that expects an input of exactly 10 characters.
 
Min length = 10
Max length = 10
 
If less then 10 characters are entered, an error message is displayed to the user.
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Technical Support
 
If you encounter any issues installing or using the Labelstar Office Lite, before requesting for the assistance of the
technical support, take advantage of the following options:
 

Update your program.
Our experience shows that many technical issues can be addressed by a software update.
The current program version can be downloaded from www.labelstar-lite.carl-valentin.de.
Search our online resources.
Our user manual covers all features of the Labelstar Office Lite and all known problems.

 
If you have not found a solution for the problem, you can request direct assistance from Carl Valentin GmbH
technical support by one of the following ways:
 

Send an email at: support@carl-valentin.de

Call by phone: +49 7720 9712 - 97
 

https://www.carl-valentin.de/en/downloads/software/labelstar-office-lite/
mailto:support@carl-valentin.de
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