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1 About This Manual
 
This documentation provides you with useful information and tips on how to use the ConfigTool.
 
Who Should Read This Manual
 
This manual is intended for administrators of Valentin label printers, direct prints and printing modules.
 
How This Manual Is Organized
 

About This Product

Installation - This section identifies the system requirements and walks you through the program installation.

Getting Started - This section provides information about the user interface and instructions on working with
the basic functions of the ConfigTool.
Program Options - This section will detail the specific options available in this dialog.

Printer Search - This section explains how to find or add printers so that they can be used within the
ConfigTool.
Printer Management - This section gives you an overview of the various options you can use to manage the
printers in your network environment.
Printer Monitoring - There are several tools available to help you monitor and troubleshoot printers in your
enterprise network. This section tells you how to use these features.
Printer Control - This section explains how you can operate and (remotely) control printers using the
ConfigTool.
Macro Programming - This section describes the ConfigTool macro facilities.

 

1.1 Document Conventions
 
The following symbols and text conventions are used in this documentation:
 
Symbol/Convention Description

  WARNING - Provides a critical warning. You should always read warnings, like this one. They
will help you avoid making serious mistakes, or wasting your time.

  IMPORTANT - Provides clarifying information or specific instructions. It is recommended
that you read the text or follow the link.

  NOTE - Provides a tip, guidance, or advice, emphasizes important information, or provides a
reference to related information.

  EXAMPLE - Provides references to sample files.

Save Name of buttons, windows, menu items and other program interface elements.

[CTRL] Keyboard keys.

C:\Windows\ Name of files and folders, code examples.

<UserName> Placeholders.

Appendix A Cross-references to other locations in the document or internal hyperlinks to web pages.
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2 About This Product
 
One For All – ConfigTool is your universal software application for updating, monitoring and controlling your label
printers, direct prints and printing modules. Flexibility and simplicity of operation are central features: printers
without an LCD display can be configured conveniently via corresponding dialog boxes. By the generation of a
printer configuration file, the settings of one or more printing systems can be saved or restored.
 

Simple updating and configuration of all printing systems

Supports all interfaces (parallel, seriell, USB, and TCP/IP)

Reading, changing, and transferring of printing parameters and options

Securing of the current printer settings in configuration files possible
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3 Installation
 
This section identifies the system requirements and walks you through the program installation.
 

Before installing ConfigTool: Please check if your computer fulfills the system requirements. This
ensures that the installation can be completed correctly.

 

3.1 System Requirements
 
Operating System
 

Windows 10/11 x64

Windows Server 2016/2019/2022 x64
 
.NET Framework
 

.NET Framework 4.7.2 or later

The installer will automatically install all required .NET Framework components

Active internet connection to update .NET Framework
 
Click the link below for instructions on installing the latest version of the .NET Framework on your computer:
 

Install the .NET Framework on Windows 10 and Windows Server 2016 and later
 

3.2 First-Time Installation
 

Administration rights are required for installation.

 
1. Download the latest version of the ConfigTool from here (under Downloads).
2. Run the downloaded file as administrator and follow the instructions on the screen.

The program is now installed on your computer and can be used.
 

https://docs.microsoft.com/en-us/dotnet/framework/install/on-windows-10
http://www.configtool.carl-valentin.de
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3.3 Update Installation
 
How do I find out if there is a new update?
 
To find out whether a new program update is available, you have the following options:
 

If the automatic update check is activated, you are automatically notified of a new update when the program
starts.
Click File > Help > Check For Updates to start the update process manually.

Just visit our website www.configtool.carl-valentin.de. Under Downloads you can always find the latest version
of the program.

 

If an older version of ConfigTool is already installed, you can just install the new version over it. There is
no need to uninstall the old version first. Your existing settings will be retained.

 
Activate Automatic Update Check
 
If you want to check automatically at program startup whether new updates are available, proceed as follows:
 
1. Click File > Options.
  The Options dialog box opens.
2. Select Check for Updates tab.
3. Select Check for updates automatically if you want to be notified when a new update is available.
4. Click OK to close the dialog box.

The automatic update check is activated.
 

To use this feature your computer must have an Internet connection and your firewall must not block
access.

 

http://www.configtool.carl-valentin.de
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4 Getting Started
 

 

Selection Area
In this area you can toogle between Groups, Configuration Files and Firmware Updates views.

Search Field
Provides a full text search over all printers in the printer list.

Printer List
All printers that can be edited are displayed here. For information on how to add printers to the printer
list, see Printer Search, and for information on how to customize the view of the printer list to suit your
needs, see Customize List View.

Info Area
Displays information on the selected printer.
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4.1 Groups View
 
For clarity, various printers can be grouped together. There are two predefined groups Network Printers and Local
Printers. Each printer is automatically, depending on the used interface type, sorted into one of these two groups.
These groups can not be edited or deleted.
 
You can also define your own groups.
 

 

To add a printer to a group or to move a printer to another group, simply drag the printer from the
printer list onto the desired group.
By right-clicking on a selected group in the tree view, you can directly add a subgroup, edit, or
delete this group.

 

4.1.1 Add Group
 
You can set up your own group of printers. Each printer can belong to one group.
 
1. Activate the Groups view.
2. Select the parent group, then perform one of the following actions:
  On the Groups tab, click Add.

Right-click in the view and select Add Group from the context menu.

  The Group dialog box opens.
3. Enter a group name.
4. Select Enable IP address range scanning if you want to assign a specific IP address range to the group. For

more information, see Search Printers in Network Area.
5. Click OK to close the dialog box.

The new group is displayed in the tree view.
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4.1.2 Edit Group
 
To change the details of a group, double-click the group in the tree view to open the corresponding dialog box.
 
Then click OK to apply the changes.
 

4.1.3 Delete Group
 
If you want to delete a group (and all related subgroups and printers), select the group in the tree view and then
press the [DEL] key on your keyboard.
 

4.2 Configuration Files View
 
Shows all files contained in the Printer Configurations Folder.
 

 
By default, the printer configurations folder is located at %ProgramData%\ConfigTool\ConfigFiles. To
change the printer configurations folder click File > Options, and then on the File Locations tab, pick a new
location.
 
ConfigTool supports the following file types:
 
Extension File Type

.cfxt Configuration file in XML format.

.cfx Configuration file in XML format (obsolte, should no longer be
used).

.prn Print file with CVPL commands.
 

To update the printer configuration or to transfer a file to a printer, simply drag the file onto the desired
printer.
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4.2.1 Edit Configuration File
 
To edit the content of a file, double-click the file in the list view to open the corresponding dialog box.
 
Then click Save to apply the changes.
 

4.2.2 Rename or Delete Configuration File
 
Right-click on the file, then choose the appropriate command from the context menu. Select Delete All if you want
to delete all files in the directory.
 

4.2.3 Duplicate Configuration File
 
Right-click on the file, then choose Duplicate from the context menu. A copy of the file appears in the list view.
 

The copied file is saved with the name of the original file by adding (2), (3), etc.

 

4.3 Firmware Updates View
 
Displays a list of the recently used firmware updates.
 

 
By default, the import folder for firmware updates is located at %ProgramData%\ConfigTool
\FirmwareUpdates. To change the firmware updates folder click File > Options, and then on the File Locations
tab, pick a new location.
 

To update the printer firmware, simply drag the firmware onto the desired printer. For more
information, see Update Printer Firmware.
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4.3.1 Import Firmware Update
 
1. Activate the Firmware Updates view.
2. Perform one of the following actions:
  On the Firmware Updates tab, click Import.

Right-click in the view and select Import from the context menu.

  The File Open dialog box opens.
3. Navigate to and select a .zip file, then click Open to start the import.

The imported firmware update is displayed in the list view.
 
For more information, see Update Printer Firmware.
 

4.3.2 Rename or Delete Firmware Update
 
Right-click on the entry, then choose the appropriate command from the context menu. Select Delete All if you
want to delete all entries at once.
 
 

4.4 Customize List View
 
You can customize the view of the printer list, by changing the column order, or by hiding certain columns.
 
Change Column Order
 
To change the column order, hover over a column header, click and drag the column to the desired location.
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Show or Hide Columns
 
Right-click on the column headings to open the context menu. Check or uncheck column names to show or hide
columns.
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5 Program Options
 
The ConfigTool has a large number of setting options with which you can customize the program to your personal
requirements.
 
It is a good idea to check through these settings before you start working with the ConfigTool. You may be
surprised at all the things you can adjust and configure!
 
To Change the Program Options
 
1. In the main window, click File > Options.
  The Options dialog opens.
2. Select the appropriate tab to configure your settings.
3. Click OK to close the dialog.

The changes are applied.
 

All settings marked with an asterix (*) take effect at the next application startup.

 

5.1 General
 
Settings
 
Automatically search for printers at startup. If this option is activated, a subnet-wide search for printers via UDP
broadcast is started at application startup.
 
Update printer status automatically. If this option is activated, the printer status of the listed printers is
automatically updated at a certain time interval. The printer states can switch between idle, printer does not answer,
unknown printer type, etc. If the printer is in an error state, you can choose whether the state should be ignored, a
notification should be displayed on the desktop or sent by email. For more information, see Update Printer Status
and Display Printer Errors.
 
Save selected view. If this option is activated, the current window configuration is saved and restored at the next
program startup.
 
Resolve IP addresses to DNS names. Turns on the use of DNS to resolve an IP address into a host name.
 
Cut DNS suffixes. DNS names often contain suffixes, for example: mary.dep1.company.com. When this option
is selected, the DNS name will be displayed as mary.
 

To speed up the scanning process, you can disable the Resolve IP addresses to DNS names option. In
this case, the program will only show IP addresses without DNS names.
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Enable metadata support. If this option is activated, the metadata tags stored in a printer are read out and
displayed in the info box of the main window. For a detailed description on how to define metadata tags for a
printer, see Edit Metadata.
 

 

Please note that not all printer types support metadata.

 

5.2 Search Settings - General
 
Here you can specify which interface types should be taken into account when searching for a printer.
 
Search Settings
 
Search printers connected to local subnet (broadcast search). Searches for all printers that are in the same
network as the computer, i.e. connected to the same router.
 
Since modern routers normally block UDP broadcasts and limit them to the local subnet, only printers are found
that are in the same network as the computer that sent the UDP broadcast request. To enable the search for
available printers in a different subnet than your own, you can define additional network areas.
 
For more information, see Printer Search.
 

For network access, ports 9099 and 9010 are used by default. Please make sure these ports are shared
on your network.

 
Search printers connected to USB. Searches for all printers that are connected to the computer via a USB
interface.
 

Please note that only those USB interfaces for which a valid printer driver is installed will be found.

 
Search printers connected to LPT. Searches for all printers that are connected to the computer via a parallel
interface.
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Search printers connected to COM. Searches for all printers that are connected to the computer via a serial
interface.
 

A printer that is connected to the computer via the serial interface can only be found if the interface
parameters exactly match the requirements of the connected printer. Since the serial interface supports
a large number of different parameters (baud rate, parity, data bits, stop bits) and it would therefore
take a long time to search through all parameter combinations, you can specify which parameters are
to be taken into account on the Search Settings > COM tab.

 

5.3 Search Settings - COM
 
Here you can specify which interface parameters should be taken into account when searching for a printer
connected to the computer via a serial interface.
 

Note that the duration to update the printer list depends on the number of parameters selected.

 
Default Settings
 

Baud rate - 9600, 19200

Parity- Keine

Data bits - 8

Stop bits - 2
 

5.4 Start/Stop Characters
 
The beginning and end of a print command are marked with the start and stop characters.
 
Example:  <SOH>FCCA - r100<ETB>  sets the print speed to 100 mm/s.
 
Predefined Start/Stop Character Combinations
 

0x01/0x17

0x5E/0x5F
 

Predefined start/stop character combinations cannot be changed or deleted.
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Settings
 
To manage the start/stop character combinations, perform one of the following actions:
 

Add new start/stop character combination
Click the Add button to define a new start/stop character combination.
Edit start/stop character combination
To edit a start/stop character combination, double-click the combination, or select the combination and then
click the Edit button.
Delete start/stop character combination
To delete a start/stop character combination, select the combination and then press [DEL] key, or click the
Remove button.

 

5.5 Firmware Updates
 
Settings
 
At a firmware update all printer settings are reset to their default values, e.g. start/stop character = 0x01/0x17,
contrast = 100%, and dispenser = off.
 
Select one of the following options to define how to proceed after a firmware update:
 

Do nothing

Restore current printer configuration
If this option is activated, the current printer configuration is read out and temporarily stored before the
firmware update is started, and transferred to the printer after the firmware update.
Restore printer configuration from file
If this option is activated, the selected .cfxt file is transferred to the printer after the firmware update. For more
information, see Manage Printer Configurations.

 

5.6 File Locations
 
Folder Settings
 
Firmware updates folder. Specifies the directory where the imported firmware updates are stored. Leave this field
blank to use the default directory: %ProgramData%\ConfigTool\FirmwareUpdates.
 
A complete list of the imported firmware updates can be found in the Firmware Updates view.
 
Printer configurations folder. Specifies the directory where the printer configurations are stored by default. Leave
this field blank to use the default directory: %ProgramData%\ConfigTool\ConfigFiles.
 
A complete list of the stored configuration files can be found in the Configuration Files view.
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Printer Definitions
 
Printer definition file. Specifies the name and location of the printer definition file. Leave this field blank to use the
default file: <InstallDir>\Printers\PrnDef.xml.
 
Printer definition files folder. Specifies the directory where the printer definition files are located. Leave this field
blank to use the default directory: <InstallDir>\Printers.
 

5.7 Language
 
You can change the language of the menus and dialog boxes used in the ConfigTool.
 
Settings
 
Select an entry from the list of available languages. If the entry (Same as the system) is selected, the system
language which is currently set (provided that the language is available, otherwise English) will be used by default .
 

If you have changed the language, you must quit and restart all ConfigTool applications that are
currently opened.

 

5.8 Check for Updates
 
Settings
 
Check for updates automatically. If this option is activated, you will be notified at program startup if a new
update is available.
 

To use this feature your computer must have an Internet connection and your firewall must not block
access.
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6 Printer Search
 
This section explains how to find or add printers so that they can be used within the ConfigTool.
 

6.1 Search Printers in Local Subnet
 
To start the printer search, perform one of the following actions:
 

On the Home tab, click Printers > Search.

Right-click in the printer list and select Search Printers from the context menu.
 
By default the local subnet and the available USB ports are searched for existing Valentin printers.
 
How can the search settings be adjusted?
 
On the Search Settings General tab in the Options dialog box you can define which interface types should be
taken into account when searching for a printer.
 
How can the printer list be updated automatically at program startup?
 
If you want the printer search to start automatically each time the program starts, activate Automatically search
for printers at startup on the General tab in the Options dialog box.
 

6.2 Search Printers in Network Area
 
By default a Broadcast search is performed, i.e. a UDP broadcast is sent to all devices. Since modern routers
normally block UDP broadcasts and limit them to the local subnet, only printers are found that are in the same
network as the computer that sent the UDP broadcast request.
 
To search for printers in a subnet other than your own, you must create a group that is assigned to a specific
network area.
 
To start the printer search in a network area, right-click the group and select Search Printers from the context
menu. The ConfigTool checks all IP addresses within the specified range one after the other.
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6.3 Add Printer
 
If you would like to use a printer and the printer search has not found what you are looking for, the ConfigTool can
help. Add the printer by hand.
 
1. Open the Add Printer wizard:
  On the Home tab, click Printers > Add.

Right-click in the printer list and select Add Printer from the context menu.

2. Select a local interface or enter the IP address of the printer you want to add, and then click Next.
3. Follow the instructions in the wizard to configure the printer.
4. Click Finish to close the wizard.

The new printer is displayed in the printer list.
 

Interfaces that are already used cannot be assigned twice.

 

6.4 Modify Invalid IP Address
 
Valentin printers are delivered with the preset IP address "192.168.0.21" which must, however, be changed in the
setup procedure. As long as the printers are in the local subnet, they will still be recognized and displayed by the
ConfigTool.
 
If your network is in the IP range 192.168.0.xxx, you can get started right away. If the status message "Invalid IP
address" is displayed, you are in a different network environment. In this case you have to assign a new IP address
that is valid for your network.
 
For a detailed description on how to change the IP address, see Change Port Settings.
 



7 Printer Management     21

 

© 2024 Carl Valentin GmbH

7 Printer Management
 
This section gives you an overview of the various options you can use to manage the printers in your network
environment.
 

7.1 Update Printer Firmware
 

Do not remove connection, cancel update, reset printer, or do other actions during update. It could be
unable to startup the printer when update failed. It can take several minutes to complete the update
process, please have some patience.

 
1. Select one or more printers, and perform one of the following actions:
  On the Home tab, click Update > Update Firmware.

Right-click and select Update Firmware from the context menu.

2. Select an existing firmware update or click Import to use a new firmware update.
3. For printers that are connected via network interface, the update is executed automatically. Otherwise follow the

instructions in the wizard.
 

A firmware update can only be executed if the printer is idle.

 
A complete list of the recently used firmware updates can be found in the Firmware Updates view.
 

7.2 Modify Printer Settings
 
One of the most important features in the ConfigTool is the ability to read out and change the current printer
settings. It is also possible to save the settings so that they can be restored later and used to configure other
printers.
 
To open the Printer Settings dialog box, perform one of the following actions:
 

Select a printer, and on the Home tab, click Settings > Printer Settings.

Right-click a printer and select Printer Settings from the context menu.

Double-click a printer.
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Search Field

You can search for a specific text in the parameter list. To set display mode, click the magnifying glass  in
the search field:

Select Show all to see all parameters.

Select Show modified only to see only the modified parameters.

Parameter List
Displays a grouped list of the parameters with their actual values. Right-click a print parameter or a group
of print parameters and select Reset from the context menu to reset the parameters to their default
values.

Description
Displays information on the selected parameter. To hide the description area, right-click on the parameter
list, and uncheck Show Description.

Buttons
Click on:

Read, to read out the actual values of the print parameters from the printer.

Update, to save the values of the print parameters to the printer.

Reset > To Factory Defaults, to reset the print parameters in the printer to their factory defaults.
Enter the password and click OK. To complete the process, the printer will restart automatically.
Configuration > Load, to load a .cfxt file.

Configuration > Save, to save your printer configuration in a printer independent .cfxt file. This
allows you to easily load a printer configuration onto a new printer or restore it after a firmware
update.
Configuration > Export, to save your printer configuration e.g. as a PDF file.

  For more information, see Manage Printer Configurations.
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7.3 Manage Printer Configurations
 
A large number of printer settings can be made in the ConfigTool. If you have set up a printer, you might want
to save the current state in order to be able to restore the printer configuration, if necessary. A conservative way
could be to write down all configuration steps in a file. However, since the settings that have been made are often
changed or undone, the effort for such documentation would be very great. Likewise, this configuration can only be
set up again "manually".
 
It is easier and more effective with .cfxt files. The printer settings are saved in these configuration files so that
they can be easily restored.
 
This section describes how you can use the ConfigTool to manage the configuration files.
 

7.3.1 Save Printer Configuration
 
1. Perform one of the following actions:
  Select a printer, and on the Home tab, click Settings > Printer Settings.

Right-click a printer and select Printer Settings from the context menu.

Double-click a printer.

  The Printer Settings dialog box opens.
2. Set up the printer the way you want.
3. Click Configuration > Save.
4. Choose a location where the .cfxt file will be saved and give it a name.

The configuration file is saved on the hard disk.
 

In order for the configuration file to be displayed in the Configuration Files view, the file must be
stored in the printer configurations folder.

 

7.3.2 Restore Printer Configuration
 
There are two ways to upload a configuration file into a printer.
 
Option 1:
 
1. Activate Configuration Files view.
2. Select .cfxt file from the list and drag it onto one or more printers.

The printer settings are updated.
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Option 2:
 
1. Perform one of the following actions:
  Select a printer, and on the Home tab, click Settings > Printer Settings.

Right-click a printer and select Printer Settings from the context menu.

Double-click a printer.

  The Printer Settings dialog box opens.
2. Click Configuration > Load.
3. Select the .cfxt file that needs to be sent to the printer.
4. Click Update.

The printer settings are updated.
 

7.3.3 Export Printer Configuration
 
A printer configuration can be exported in various file formats that can be used in other applications.
 
1. Perform one of the following actions:
  Select a printer, and on the Home tab, click Settings > Printer Settings.

Right-click a printer and select Printer Settings from the context menu.

Double-click a printer.

  The Printer Settings dialog box opens.
3. Click Configuration > Export.
4. Select a file format in Save as type list:
  *.pdf - Portable Document Format

*.xlsx - Excel spreadsheet

*.csv - Formatted text file

*.txt - Unformatted text file

5. Choose a location where the file will be saved and give it a name.
The file is saved on the hard disk.

 

7.4 Change Port Settings
 
You can change the connection settings for the following interface types in the ConfigTool:
 

Serial Port

Network Port

Wireless Network Port
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To open the appropriate dialog box, perform one of the following actions:
 

Select a printer, and on the Home tab, click Settings > Port Settings, and then select the interface type you
want to configure.
Right-click a printer and select Port Settings from the context menu, and then select the interface type you
want to configure.

 

7.4.1 Wireless Network Port
 

WLAN settings cannot be changed via WLAN. To configure the WLAN interface of a printer you
need to access the printer via network.
For communication the ports 4201 and/or 23 are used by default. Please make sure that these ports
are shared in your network.

 

 

Please note that the printer-internal WLAN module needs about 1 minute to restart after each data
transfer.

 
A detailed description of the WLAN module used in the printer can be found here: <InstallDir>
\Documentation\140-20151-100-SX-590_Manual_eng.pdf. The console commands are summarized in
Appendix B of this manual.
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7.4.1.1 Troubleshooting
 
There are many reasons why you cannot make a WLAN connection to the printer.
 
WLAN is not working: Am I online at all?
 
At first, you should try to establish the WLAN connection to another device. This way, you can find out if the WLAN
is generally not working or if the printer is causing problems.
 
Without the correct WLAN password, nothing will happen
 
Normally the WLAN is password protected. To establish a WLAN connection to the printer you must enter the SSID,
the encryption type and the password (case sensitive).
 

 
WLAN wireless problems: Do you have enough range?
 
Often problems occur e.g. through reinforced concrete in new buildings. This has a strong shielding effect and your
WLAN signal is already weak after only one or two walls that no connection can be established.
 
Avoid WLAN interference
 
Even sources of interference like other electrical devices can block your WLAN network. You should switch off these
devices or even better, place the devices somewhere else. WLAN interferences can also occur if too many users use
the same wireless channel. In this case, it helps if you move in the settings of your router to another channel.
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Protection mechanism blocks WLAN
 
If you are sure that the WLAN settings are correct and the WLAN signal is not blocked but the connection still does
not work, it is probably because the MAC filter is enabled in the router.
 
The MAC address (Media Access Control Address) is the fixed, worldwide unique hardware address of each network
device. In most WLAN routers you can specify that only certain WLAN devices are allowed to connect – filtering is
effected via the MAC address. Check in the router if this option is activated. Sometimes it calls itself „restrict access
to known WLAN devices“.
 
Either enter the MAC address of the new device of deactivate the MAC filtering completely.
 

7.5 Change Date and Time
 
Date and Time are factory preset and may be changed manually.
 
1. Perform one of the following actions:
  Select a printer, and on the Home tab, click Settings > Other Settings > Date and Time.

Right-click a printer and select Other Settings > Date and Time from the context menu.

  The Date and Time dialog box opens.
2. Choose Synchronize with system date and time, or enter the new date and time manually.
3. Click Update.

The date and time is updated in the printer.
 

7.6 Modify Password Settings
 
The ConfigTool enables you to protect printer access with a password. In addition, various printer functions can be
restricted with the password.
 
The following printer functions can be restricted:
 

Functions Menu
Prevents access to the Functions menu. Printer settings (e.g. contrast, print speed, operating mode) can be
changed in the function menu.
Favorites List
Prevents access to the Favorites list.
Manual Reprint
Prevents the manual reprint of a label at the printer.
Memory Card
Prevents access to the Memory Card. Access to the standard directory can be allowed.
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To open the Password dialog box, perform one of the following actions:
 

Select a printer, and on the Home tab, click Settings > Other Settings > Password.

Right-click a printer and select Other Settings > Password from the context menu.
 

If the printer access is password protected in the ConfigTool, you need to enter the password for the
printer only once. As long as you do not exit the ConfigTool, you do not have to enter the password
again.

 

7.7 Edit Metadata
 

Metadata tags are not available for all printer types.

If you get the error message "No metadata available." you may need to update the printer firmware
to a newer version.

 
What is Metadata?
 
Metadata enriches the printer with information that makes it easier to find, use and manage. This could be, for
example, the location of the printer or the person who should be contacted when an error occurs.
 
Metadata tags are always structured the same. They consist of a title and a description. ConfigTool enables you to
define your own metadata. This allows you to adapt the metadata stored in the printer to your own needs.
 
Show Metadata
 
The metadata of the selected printer is displayed in the info box of the main window along with permanently
generated information such as port, printer type and current firmware version. In order for the metadata to be
displayed, you must activate Enable metadata support on the General tab in the Options dialog box.
 

 
Manage Metadata
 
You can view and edit a printer's metadata in the Metadata dialog box.
 
To open the dialog box, perform one of the following actions:
 

Select a printer, and on the Home tab, click Settings > Other Settings > Metadata.

Right-click a printer and select Other Settings > Metadata from the context menu.
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To manage the metadata tags, perform one of the following actions:
 

Add new metadata tag
Make sure that no items are selected in the list. Enter the title and description in the two input fields and click
Add.
Edit metadata tag
Select an item in the list and change the title and description.
Delete metadata tag
Select an item in the list, and then press [DEL] key or click the Remove button.
Delete all metadata tags
Click the Clear button if you want to delete all items in the list.
Import metadata tags
To add multiple tags to the list, click the Import button and load the appropriate .cfm file.
Export metadata tags
Click the Export button if you want to export the list to a .cfm file.

 

7.8 Change HMI Logo
 

This button is only visible if the program is started with the command line parameter "-hmilogo".

 
1. Perform one of the following actions:
  Select a printer, and on the Tools tab, click Utilities > Change HMI Logo.

Right-click a printer and select Tools > Change HMI Logo from the context menu.

  The HMI Logo dialog box opens.
2. Click Choose File to select an image file.
  The supported image file formats are Windows bitmap (.bmp), Portabel Network Graphic (.png), and JPEG (.jpg).
3. Click Upload Logo.

The new logo is shown in the printer display.
 

The logo is recommended to be no larger than 230 x 78 pixels. Anything larger will be scaled to fit the
designated logo size.
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8 Printer Monitoring
 
There are several tools available to help you monitor and troubleshoot printers in your enterprise network. This
section tells you how to use these features.
 

8.1 Update Printer Status
 
Update Printer Status Manually
 
To update the printer status, select one or more printers, and perform one of the following actions:
 

On the Home tab, click Update > Update Status.

Right-click and select Update Status from the context menu.

 
Update Printer Status Automatically
 
You can also update the printer status automatically at regular intervals. Activate Update printer status
automatically on the General tab in the Options dialog box. Here you can also specify a time interval in seconds
with which the automatic update should take place. By default, the interval is set to 30 seconds.
 

8.2 Display Printer Errors
 
If the printer status is updated automatically, you can define whether you want to be notified if a printer error
occurred. Click File > Options, and on the General tab, choose an option from the On printer errors drop-down
list:
 

Do nothing

Show desktop notification

 

Show email notification
Click Setup Email Settings to define the email address the notification is to be sent to.

 
For information on how to reset a printer error, see Printer Commands.
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8.3 Monitor Photocells
 
You can use this feature to check if the built-in photocells are configured correctly.
 
1. Select a printer, and perform one of the following actions:
  On the Tools tab, click Support > Monitor Photocells.

Right-click and select Tools > Monitor Photocells from the context menu.

  The Photocells dialog box opens.
2. If there are multiple network adapters in the computer, select the corresponding adapter for which the

connection to the printer should be established.
3. Click Start.

Monitoring is started.
 

 
Click Test Print, or Label Feed, or slowly pull the label. If the photocell is configured correctly, the value drops as
soon as the photocell detects the gap between the labels.
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8.4 Print Storage Viewer
 

With this feature you can read out the contents of the print memory if a print job is currently active in
the printer.

 
To open the Print Storage dialog box, perform one of the following actions:
 

Select a printer, and on the Tools tab, click Support > Print Storage Viewer.

Right-click a printer and select Tools > Print Storage Viewer from the context menu.
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8.5 Logging
 
When troubleshooting printer problems, it can be very helpful to evaluate the log files generated by the printer.
These log files contain information about printer status and events that can be very helpful in diagnosing a
problem.
 
The printer supports various types of logging, including (amongst other) the following log types:
 

Trace Log - Logs general information.

Error Log - Logs errors that occurred while printing.

Net Log - Logs printer commands send to the printer.

Chart Log - Records the events generated during a print job.

Config Log - Displays the current printer settings.
 

8.5.1 Create Log File
 
1. Select a printer, and perform one of the following actions:
  On the Tools tab, in the Support > Logging group, click Data Logger or Chart Logger.

Right-click and select Logging > Data Logger or Chart Logger from the context menu.

  The Log Viewer dialog box opens.
2. Reproduce the issue.
3. Click Save Log Files, select the desired location, and then click Save.

The log files are stored in a .zip file.
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8.5.2 Open Log File
 
To open a previously saved log file, perform one of the following actions:
 

On the Tools tab, click Support > Logging > Open Logs.

Right-click in the printer list and select Logging > Open Logs from the context menu.
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9 Printer Control
 
This section explains how you can operate and (remotely) control printers using the ConfigTool.
 

9.1 Printer Commands
 
Valentin printers support the CVPL printer language. CVPL (CV Programming Language) is a command based
language used to control the printer directly.
 
To send a printer command, select one or more printers, and perform one of the following actions:
 

On the Home tab, click Commands > Printer Commands.

Right-click and select Printer Commands from the context menu.
 

 
If you would like to send other printer commands to the printer, use the Command Editor.
 

9.2 Remote Console
 
The Remote Console can be used as a "remote control" for the printer. In the Remote Console dialog box
shortcuts can be simulated and the content of the printer display is shown.
 
The Remote Console is a standalone application that runs independently of the ConfigTool, but can also be called
from the ConfigTool.
 
Start Application under Windows
 

Open the Windows start menu and search for Remote Console.

Enter the IP address of the label printer and click OK.
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Start Application from the ConfigTool
 
To open the Remote Console dialog box from the ConfigTool, perform one of the following actions:
 

Select a printer, and on the Tools tab, click Utilities > Remote Console.

Right-click a printer and select Tools > Remote Console from the context menu.
 

 

9.2.1 System Menu
 
The Remote Console has an extended system menu.
 

 
In addition to the default menu items Move, Minimize and Close, there are also the following menu items:
 

New Remote Connection - Enter the IP address of the label printer and click OK.

Close All - Closes all open windows and exits the program.
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9.2.2 Key Codes
 
The following table lists the functions and the associated key codes defined in conjunction with the Remote
Console.
 
Button
(Keypad)

Button
(Keyboard)

Function

Basic Menu/Test Print

Function Menu

Print Menu

Memory Card Menu

Label Feed

Start/Stop

Move up

Move left

Move right

Move down
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9.3 Command Editor
 
Using the Command Editor you can send commands easily and comfortable to the printer.
 
To open the Command Editor dialog box, perform one of the following actions:
 

Select a printer, and on the Tools tab, click Utilities > Command Editor.

Right-click a printer and select Tools > Command Editor from the context menu.
 

 
Enter a CVPL command in the command line, or select a command from the list and click on the related link. Press
[ENTER] key to execute the command. A complete description of the supported CVPL commands can be found in
the interface description of your Valentin printer.
 
Useful Tips
 

Previous command history - the up/down arrow keys
The command editor remembers all the commands that you recently typed in. At any time, you can set the text
of your command to any of these previous commands, as if you had just typed it in. It is then trivial to go back

and edit those sections that need to be amended. By scrolling with the up  and down  arrow keys, you can
access previously typed commands -- including the ones with typos.
Command completion - the TAB key
When you partially enter a command, the command-completion feature either automatically completes your
command or displays a suggested list of commands. To prompt command completion, enter the beginning of a
command and press the [TAB] key.
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10 Macro Programming
 
The ConfigTool supports macro programming with the IronPython language. Macros are functions within script
files, identified as modules, that are executed by the integrated interpreter.
 
To execute a macro, perform one of the following actions:
 

Select a printer, and on the Home tab, click Update > Run Script File.

Right-click a printer and select Run Script File from the context menu.
 
To be a valid macro, the module MUST define the Run function:
 

def Run(portName, deviceId):

    ...

 
This function is called by the ConfigTool to start execution.
 

IronPython is a case-sensitive programming language, so e.g. "Run" is not the same as "run".
Variables, functions, and objects in IronPython must be called exactly how they are named,
including the case.
To create and test a script file a development environment (e.g. Visual Studio) should be used.

 

10.1 Script API
 
In this section you will find a list of the objects and functions provided by the ConfigTool for use within a script.
 
Functions
 

def Run(portName, deviceId):

    ...

 
This function is called by the ConfigTool to start the execution of the the macro.
 
Parameter Data Type Description

portName String Port (IP address, USB port, ...) to which a connection is to be established.

deviceId String Unique device ID.
 
Return Value
 
None
 

https://ironpython.net/
https://ironpython.net/
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Variables
 
Name Data

Type
Description

IsCancellationRequested Integer Read-only
1 if the user has canceled the update, 0 otherwise.

 
Exceptions
 
Name Description

UserCancelException This exception should be thrown whenever the user cancelled the update, i.e. when the
IsCancellationRequested variable is equal to 1.

if IsCancellationRequested:

   raise UserCancelException

ProcessError This exception should be thrown if an error occurs during the update.

if "Idle" not in data.decode():

   raise ProcessError("Printer is not idle!")
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10.2 Code Sample
 

More code samples and a test application in C# can be found in the following location: C:\Users
\Public\Documents\ConfigTool\Samples.

 
The following code sample shows how to establish a TCP connection to a printer and get the current printer status.
If the printer is idle a test print is released.
 

import _socket

from _socket import *

 
from time import sleep

 
def Run(portName, deviceId):

 
   try:

      TCP_PORT = 9100

      BUFFER_SIZE = 1024

 
      print("Waiting for connection...")

      s = socket(AF_INET, SOCK_STREAM)

      s.connect((portName, TCP_PORT))

 
      print("Socket connected successfully to " + portName + ":" + str(TCP_PORT))

      sleep(2)

 
      if IsCancellationRequested:

         raise UserCancelException

 
      print ("Read printer status...")

      message = "\x01SE\x17"

      s.send(bytes(message, "ascii"))

      data = s.recv(BUFFER_SIZE)

 
      print("Printer status: " + data.decode())

      if "Idle" not in data.decode():

         raise ProcessError("Printer is not idle!")

      sleep(2)

 
      if IsCancellationRequested:

         raise UserCancelException

 
      print("Release test print...")

      message = "\x01FF----r\x17"

      s.send(bytes(message, "ascii"))

 
   finally:

       s.close()

 



42     11 Technical Support

 

© 2024 Carl Valentin GmbH

11 Technical Support
 
If you encounter any issues installing or using the ConfigTool, before requesting for the assistance of the technical
support, take advantage of the following options:
 

Update your program.
Our experience shows that many technical issues can be addressed by a software update.
You can download the current program version from our website under Downloads: www.configtool.carl-
valentin.de.
Search our online resources.
Our user manual covers all features of the ConfigTool and all known problems.

 
If you have not found a solution for the problem, you can request direct assistance from Carl Valentin GmbH
technical support by one of the following ways:
 

Send an email at: support@carl-valentin.de

Call by phone: +49 7720 9712 - 97
 

http://www.configtool.carl-valentin.de
http://www.configtool.carl-valentin.de
mailto:support@carl-valentin.de
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Appendix A - Command Line Parameters
 
Use the command line parameters below to customize the ConfigTool startup.
 
To add a command line parameter
 
Right-click the program shortcut, and edit the program target path.
Example: "C:\Program Files\Carl Valentin GmbH\ConfigTool\ConfigTool.exe" -hmilogo
 
Available parameters
 
Parameter Description

-help Opens the ConfigTool help.

-hmilogo If this command line parameter is specified, the Change HMI Logo button is visible.
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